Функция СЧЕТЕСЛИ в Excel и примеры ее использования

Округление числа с помощью формата ячеек

Формат ячеек позволит выбрать необходимое количество цифр, которое должно отображаться в числе после запятой.

Округлять будем число 23,5168 в ячейке А1. Кликаем по нему правой кнопкой мыши и из контекстного меню выбираем «Формат ячеек».

okruglenie-v-excel-2.jpg

Дальше, на вкладке «Число» из списка «Числовые форматы» выберите «Числовой». В поле «Число десятичных знаков» поставьте нужное значение. Нажмите «ОК».

okruglenie-v-excel-4.jpg

Количество знаков после запятой уменьшилось до 2-х. Как видите, округление числа происходит по математическим законам: если отбрасываемая цифра меньше пяти – число округляется в меньшую сторону, если больше пяти или равно – в большую.

Значение в ячейке изменилось только визуально. В строке формул по-прежнему стоит число 23,5168, и именно оно будет браться для любых расчетов, в которых будет указана ячейка А1.

Чтобы уменьшить или увеличить количество знаков после запятой, можно использовать и следующий способ. На вкладке «Главная» в группе «Число» Вы найдете две кнопочки «Увеличить разрядность» и «Уменьшить разрядность».

Читайте еще:  Как подключить вай фай к телевизору LG

Выделим ячейку А1 и нажмем один раз на кнопку «Уменьшить разрядность». Получим вот такой результат.

Как сравнить данные в двух таблицах

Пользователям часто приходится сравнить две таблицы в Excel на совпадения. Примеры из «жизни»: сопоставить цены на товар в разные привозы, сравнить балансы (бухгалтерские отчеты) за несколько месяцев, успеваемость учеников (студентов) разных классов, в разные четверти и т.д.

Чтобы сравнить 2 таблицы в Excel, можно воспользоваться оператором СЧЕТЕСЛИ. Рассмотрим порядок применения функции.

Для примера возьмем две таблицы с техническими характеристиками разных кухонных комбайнов. Мы задумали выделение отличий цветом. Эту задачу в Excel решает условное форматирование.

Исходные данные (таблицы, с которыми будем работать):

funkcii-excel2-7.png

Выделяем первую таблицу. Условное форматирование – создать правило – использовать формулу для определения форматируемых ячеек:

Читайте также:  Age of empires iii обзор

funkcii-excel2-8.png

В строку формул записываем: =СЧЕТЕСЛИ (сравниваемый диапазон; первая ячейка первой таблицы)=0. Сравниваемый диапазон – это вторая таблица.

Чтобы вбить в формулу диапазон, просто выделяем его первую ячейку и последнюю. «= 0» означает команду поиска точных (а не приблизительных) значений.

Выбираем формат и устанавливаем, как изменятся ячейки при соблюдении формулы. Лучше сделать заливку цветом.

Выделяем вторую таблицу. Условное форматирование – создать правило – использовать формулу. Применяем тот же оператор (СЧЕТЕСЛИ).

Здесь вместо первой и последней ячейки диапазона мы вставили имя столбца, которое присвоили ему заранее. Можно заполнять формулу любым из способов. Но с именем проще.

Когда используешь различные функции «Если», «Суммесли», то часто в них задаешь условия, при которых должно выполняться определенное условие. При этом действительно часто используются разные знаки сравнения, так как с их постановкой возникает проблемы, то давайте покажем, как их поставить.

Поставим в экселе знак больше или равно.

Перед нами таблица, в которой есть числа от 1 до 10. В рядом стоящем столбце, нужно прописать функцию «ЕСЛИ», с условием, что если цифра больше или равно трем ставиться «Да», а если условие не выполняется, то ставиться «Нет».

В ячейке «В2» пропишем формулу: =ЕСЛИ(A2>=3;»Да»;»Нет»), где знак >= означает больше или равно. Копируем данную формулу на все ячейки.

Поставим в экселе знак меньше или равно.

Поменяем задачу, теперь поставим «Да», если числом меньше или равно трем, а при невыполнении условия ставим слово «Нет». Для этого в ячейке «В2» пишем формулу =ЕСЛИ(A2 3;»Нет»;»Да»), где знаком <> мы обозначаем неровно трем.

Примечание: Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке).

Читайте также:  Ручной отпариватель для одежды филипс отзывы

Проверка истинности условий и логических сравнений между выражениями, которые являются общими для многих задач. Для создания условных формул можно использовать функции » и», «,» и » Если «.

Например, функция Если использует указанные ниже аргументы.

Формула, использующая функцию если

лог_выражение: условие, которое нужно проверить.

значение_если_истина: возвращаемое значение, если условие истинно.

значение_если_ложь: возвращаемое значение, если условие имеет значение false.

Дополнительные сведения о том, как создавать формулы, можно найти в разделе Создание и удаление формул.

Синтаксис и особенности функции

Сначала рассмотрим аргументы функции:

  • Диапазон – группа значений для анализа и подсчета (обязательный).
  • Критерий – условие, по которому нужно подсчитать ячейки (обязательный).

В диапазоне ячеек могут находиться текстовые, числовые значения, даты, массивы, ссылки на числа. Пустые ячейки функция игнорирует.

В качестве критерия может быть ссылка, число, текстовая строка, выражение. Функция СЧЕТЕСЛИ работает только с одним условием (по умолчанию). Но можно ее «заставить» проанализировать 2 критерия одновременно.

Рекомендации для правильной работы функции:

  • Если функция СЧЕТЕСЛИ ссылается на диапазон в другой книге, то необходимо, чтобы эта книга была открыта.
  • Аргумент «Критерий» нужно заключать в кавычки (кроме ссылок).
  • Функция не учитывает регистр текстовых значений.
  • При формулировании условия подсчета можно использовать подстановочные знаки. «?» — любой символ. «*» — любая последовательность символов. Чтобы формула искала непосредственно эти знаки, ставим перед ними знак тильды (~).
  • Для нормального функционирования формулы в ячейках с текстовыми значениями не должно пробелов или непечатаемых знаков.

Заключение

В данной статье были рассмотрены различные способы применения функции «ЕСЛИ»:

  • самый простой случай;
  • с несколькими условиями;
  • с применением дополнительных операторов;
  • с использованием арифметических символов и прочие варианты.

Если вдруг у вас что-то не получилось, возможно, вы допускаете где-нибудь опечатку. Так же распространенной ошибкой большинства является неправильная логика в условиях.

Функция СЧЕТЕСЛИ в Excel: примеры

Посчитаем числовые значения в одном диапазоне. Условие подсчета – один критерий.

У нас есть такая таблица:

Посчитаем количество ячеек с числами больше 100. Формула: =СЧЁТЕСЛИ(B1:B11;»>100″). Диапазон – В1:В11. Критерий подсчета – «>100». Результат:

Если условие подсчета внести в отдельную ячейку, можно в качестве критерия использовать ссылку:

Посчитаем текстовые значения в одном диапазоне. Условие поиска – один критерий.

Формула: =СЧЁТЕСЛИ(A1:A11;»табуреты»). Или:

Во втором случае в качестве критерия использовали ссылку на ячейку.

Формула с применением знака подстановки: =СЧЁТЕСЛИ(A1:A11;»таб*»).

Для расчета количества значений, оканчивающихся на «и», в которых содержится любое число знаков: =СЧЁТЕСЛИ(A1:A11;»*и»). Получаем:

Формула посчитала «кровати» и «банкетки».

Используем в функции СЧЕТЕСЛИ условие поиска «не равно».

Формула: =СЧЁТЕСЛИ(A1:A11;»<>»&»стулья»). Оператор «<>» означает «не равно». Знак амперсанда (&) объединяет данный оператор и значение «стулья».

При применении ссылки формула будет выглядеть так:

Часто требуется выполнять функцию СЧЕТЕСЛИ в Excel по двум критериям. Таким способом можно существенно расширить ее возможности. Рассмотрим специальные случаи применения СЧЕТЕСЛИ в Excel и примеры с двумя условиями.

  1. Посчитаем, сколько ячеек содержат текст «столы» и «стулья». Формула: =СЧЁТЕСЛИ(A1:A11;»столы»)+СЧЁТЕСЛИ(A1:A11;»стулья»). Для указания нескольких условий используется несколько выражений СЧЕТЕСЛИ. Они объединены между собой оператором «+».
  2. Условия – ссылки на ячейки. Формула: =СЧЁТЕСЛИ(A1:A11;A1)+СЧЁТЕСЛИ(A1:A11;A2). Текст «столы» функция ищет в ячейке А1. Текст «стулья» — на базе критерия в ячейке А2.
  3. Посчитаем число ячеек в диапазоне В1:В11 со значением большим или равным 100 и меньшим или равным 200. Формула: =СЧЁТЕСЛИ(B1:B11;»>=100″)-СЧЁТЕСЛИ(B1:B11;»>200″).
  4. Применим в формуле СЧЕТЕСЛИ несколько диапазонов. Это возможно, если диапазоны являются смежными. Формула: =СЧЁТЕСЛИ(A1:B11;»>=100″)-СЧЁТЕСЛИ(A1:B11;»>200″). Ищет значения по двум критериям сразу в двух столбцах. Если диапазоны несмежные, то применяется функция СЧЕТЕСЛИМН.
  5. Когда в качестве критерия указывается ссылка на диапазон ячеек с условиями, функция возвращает массив. Для ввода формулы нужно выделить такое количество ячеек, как в диапазоне с критериями. После введения аргументов нажать одновременно сочетание клавиш Shift + Ctrl + Enter. Excel распознает формулу массива.

СЧЕТЕСЛИ с двумя условиями в Excel очень часто используется для автоматизированной и эффективной работы с данными. Поэтому продвинутому пользователю настоятельно рекомендуется внимательно изучить все приведенные выше примеры.

Оцените статью
Рейтинг автора
5
Материал подготовил
Илья Коршунов
Наш эксперт
Написано статей
134
Добавить комментарий